Discuz 应用中心安装模板时候提示版本号不匹配(解决方法)

从Discuz官方的应用中心安装模板时,就算模板作者设定了允许这个程序版本使用该模板,但在实际安装的时候依然提示版本号不匹配

这是什么原因?

经过分析发现,是因为Discuz X3 和 X3.1、X3.2的模板是完全兼容的。而很多模板在X3的时候发布,应用中心的机制就是需要版本号统一,就算3个版本通用也不行。

之前的版本中,就算提示版本号不同,也是可以强制安装的,在X3.1之后,就不能强制安装了。

下面我们就来使用X3的模板安装到X3.2为例子讲解。

Discuz 应用中心安装模板时候提示版本号不匹配(解决方法)
官方发布的升级版版本号还是X2.5的

不影响演示。

我们打开 template/你的模板目录/discuz_style_qing.xml 文件,在里面找到X2.5。

将这个X2.5给修改后即可。

这个里注意:修改的依据完全更具你的提示进行修改,提示需要什么,你就修改成什么。

修改之后,保存,刷新后进入后台即可成功。

注明:本文为星速云原创版权所有,禁止转载,一经发现将追究版权责任!

(0)
上一篇 2022年7月20日 下午7:58
下一篇 2022年7月20日 下午7:58

相关推荐

发表评论

登录后才能评论
问答社区 QQ客服
微信客服
微信客服
分享本页
返回顶部