WordPress 更新版本或插件出现输入FTP账号密码(需要访问权限等问题)

其实在之前没有配置网站安全方面的前提下,Wordpress 是能正常更新并且正常下载插件的。

但是在之前因为网站被人入侵了两次。

相关阅读:《WordPress网站被入侵,劫持收录事件记录》,这是第一次,第二次没有记录,因为问题在某客户下载了盗版插件导致整个服务器的网站遭殃。

警惕性一下就高了,所以把全站权限全部设置成“555”。之前安装了云锁,现在除了云锁多上了宝塔的防火墙。双重保险。

那么问题来了,WP后台更新的时候,需要让你输入FTP才能更新,于是我输入FTP账号密码,也不能正常更新,并且插件也没法下载。

Wordpress 更新版本或插件出现输入FTP账号密码(需要访问权限等问题)

自己就在百度上找了些方法,把他归纳整合起来,有些方法使用一部即可成功,有些则不行,需要一一排查。

一、wp-config.php文件添加修改

直接编辑根目录wp-config.php,在底部添加以下代码,一般在加入下面代码后就可以正常更新了。

define("FS_METHOD", "direct");
define("FS_CHMOD_DIR", 0777);
define("FS_CHMOD_FILE", 0777);

我试着添加之后,发现确实可以更新,但是最后提示的是更新失败,并没有完全解决我的问题。

二、将网站整个目录改成“755”权限

为什么要将整个目录权限修改?因为我按照网上说的:将/wp-content/这个目录设置成“755”,并不能正常升级(有些人可以,但是我这里不行)。

所以我将整个网站的所有目录都设置成“755”权限(管理员,可读取,可写入,可执行)。

Wordpress 更新版本或插件出现输入FTP账号密码(需要访问权限等问题)

总结

我做到以上两步后,网站就可以正常更新了。

因为并不能准确找到原因,所以很多我都是一步步试出来的。其中我多次重启nginx服务和网站。不知道这两个方法是否可以带来效果,反正各位在遇到问题,多多尝试。

注明:本文为星速云原创版权所有,禁止转载,一经发现将追究版权责任!

(0)
上一篇 2022年8月4日 下午12:28
下一篇 2022年8月4日 下午12:28

相关推荐

发表评论

登录后才能评论
问答社区 QQ客服
微信客服
微信客服
分享本页
返回顶部